Announcement Announcement Module
No announcement yet.
OpenSSL - Heartbleed vulnerability- CVE-2014-0160 Page Title Module
Move Remove Collapse
Conversation Detail Module
  • Filter
  • Time
  • Show
Clear All
new posts

  • OpenSSL - Heartbleed vulnerability- CVE-2014-0160

    The Heartbleed Bug is a potential vulnerability in the openSSL crypto software library. This bug allows stealing the information protected under normal conditions by the SSL/TLS encryption used to secure the internet.

    The Heartbleed bug allows anyone on the Internet to read the memory of the systems protected by the vulnerable versions of the OpenSSL software. This compromises the secret keys used to identify the service providers and to encrypt the traffic, the names and passwords of the users and the actual content. This allows attackers to eavesdrop on communications, steal data directly from the services and users and to impersonate services and users.

    How to test if your server is vulnerable with heartbleed?

    You can test it using these following URLs.

    Full details regarding this bug is detailed here in this FAQ

    CloudLinux 5/ CentOS 5/ RHEL 5 servers are not affected by this issue as per:

    Regarding CentOS 6 and RHEL 6.4 higher servers, we need to update openSSL to version openssl-1.0.1e-16.el6_5.7 which is the patched one from this bug.

    To check a CentOS 6 system has the backported fix (probably running 1.0.1e),
    run the following:

    rpm -q openssl --changelog | head -n3

    Which should return the following:

    * Mon Apr 07 2014 Tomáš Mráz <> 1.0.1e-16.7
    - fix CVE-2014-0160 - information disclosure in TLS heartbeat extension

  • #2
    Also make sure that all the services that are using the Openssl are restarted after updating the Openssl.

    You can find all the services using openssl by issuing the below command:
    # lsof -n | grep -iE '' | awk '{print $1}' | sort | uniq
    # lsof -n | grep -iE '' | awk '{print $1}' | sort | uniq

    Until we restart the services , they will use the old vulnerable version of Openssl.

    Thanks :-)


    • #3